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Introduction to PlantSim™ 
What is PlantSim? 
PlantSim is a full-scope, high fidelity training simulator in the form of an inexpensive, 
generic training simulator. 

PlantSim, by nHance Technologies, was developed in 2003 in an effort to bring the power of full- 
scope training simulators to customers who may not have the budget for a plant-specific simulator. 

PlantSim Capabilities 
PlantSim models can be distributed in two ways: 

1. On a network of PCs to simulate the control room environment, or  

2. All of the functions can be combined onto a single laptop PC for convenient individual training.  

In addition to the dynamic plant process model, PlantSim also includes the following:  

� Instructor Station: Simulator runtime executive.  
Trending graphics are used to control the simulator events and observe the training session.  

� Operator Station: Trainee interface to the simulator.  
The Operator Station uses emulated graphics for the DCS operator stations that mimic the plant 
control room.  

The model is supplied with a complete set of Initial Condition (IC) files and malfunctions with plant 
startup and shutdown instructions. 

 

Using PlantSim 
Starting the Model 
A model must be running before you can use the HMI.  In order to start a model, the nHance security 
key must be properly installed on the machine (See the Security Key section in Installation 
Instructions document for details.)  

To start the model, follow these steps: 

1. Open Simulation Master (S_Master) from the Windows START menu.  
Since S_Master acts as a server application, Windows might display a security warning for 
S_Master. If so, just select “Unblock.” 

3. Load the Model project file (*.prj). 
The main window of S_Master will show the currently loaded project.  If no project is loaded or to 
select a different model, select File à Load RunTime Model from the main menu. Browse to 
.prj file and select Open (a typical location is c:\myMMS\Models\PS4\PS4Sim0\PS4SIM0.prj). 
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4. Start/Stop the Simulation. 
Once a model project file is loaded, you can control the simulation from the main menu by 

selecting Simulation > Start or Stop, or by clicking the green start button  or the red stop 

button . 

*The model may take several minutes to start depending on the speed of your machine. 

5. When the model is running, the model status and run-time will be updated in the lower status bar 
as shown below: 

 

 
Figure 1: Notice the status “RUN” in the bottom bar, and the run-time of 52592.000 Sec. 

 

6. S_Master will open an ACSL window that is referred to as the “ACSL run-time” window.  S_Master 
sends commands to the ACSL environment to control the model startup. Do not close this 
window. Closing the ACSL run-time window will close the model simulation. 

Starting the HMI 
From the Windows start menu select “PlantSim HMI” to open the default MMI screen. The MMI 
Manager will load automatically and connect to the model.   

Controlling the Model 
For step-by-step instructions on controlling the model once it is started, see the Using the Action 
Center section. 

Configuring PlantSim 
Most of the required settings to start PlantSim are configured during installation.  The PlantSim HMI 
consists of a collection of exe “screens” located typically in C:\PlantSim\PS#\MMI (where # is the 
PlantSim Unit number). 

The PlantSim exe simply configures the appropriate personality settings for MMI manager and 
launches one or more MMI screen exe’s (See Using Multiple Monitors with PlantSim below.) 

The PlantSim shortcut is setup by the installation program.  
The following is intended for information only: 
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Shortcut Properties: 

� Target:  
<PlantSim Install Dir>\PlantSim.exe <Unit_Number> 

� Start In:  
<PlantSim HMI Dirr> 

� PlantSim Install Dir.:  
The location of PlantSim.exe 

� Unit_Number:  
The PlantSim Unit Number is a required command line parameter for PlantSim.exe to select the 
proper HMI 

� PlantSim HMI Dir:   
The location of the HMI which is determined by the PlantSim installation program.  This folder 
MUST contain all the HMI exe’s as well as the configuration files used to start the HMI. 

PSConfig INI 
The INI file is used to setup the registry with the proper data for the MMI32 program to locate the 
proper files.  The INI file is named as: PS<#>Config.INI (# = PlantSim Unit Number) and has the 
following parameters: 

� WriteRegKey 
Required data for MMI32 

� MMI_Path 
PlantSim HMI installed location  

� Menu_Exe 
Required data for MMI32 

� Toolba_Exe 
Required data for MMI32 

� DefScreen 
Initial screen used to start the HMI (may be changed to display different screen on startup of the 
HMI) and may also include a DDN (or PC monitor number for multiple monitor systems) If no DDN 
number is supplied, the DDN will default to 1.  

For example: 
DefScreen = 4gmenu.exe 1 

� HMIstart1 
Additional screens can be started by PlantSim by adding additional lines to the INI file starting 
with HMIstart1. The screen exe should be followed by the DDN. 

For example:  
HMIstart1 = 4cmenu.exe 2 
HMIstart2 = 4AGM1.exe 3  
HMIstart3 = ps4hp1.exe 4  

PlantSim.exe parameters 
The PlantSim.exe has the following command line options for starting the HMI: 
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1. PlantSim Unit number  
(1, 2, 3, or 4, depending on the PlantSim model you are using) 

2. Startup Mode (0 or 1) 
0 = normal, 1 = debug (verbose mode while starting PlantSim). 

3. Startup screen exe  
The initial screen used to start the HMI (NOTE: This will override the PSConfig INI setting 
DefScreen.) 

4. DDN for the screen 

 

Using Multiple Monitors with PlantSim 
The MMI32 application supports multiple monitor configurations using DDN numbers. (see Glossary)  
The DDN is a parameter passed to the MMI32 to control how an MMI screen is positioned.  For 
example, a DDN of 2 would start the MMI screen on PC screen 2 as identified by the Windows Display 
Properties: 

 

To start multiple screens when using PlantSim, modify the PSConfig INI file (described above) to add 
the following line (where MMI_screen is the desired screen exe): 
HMIstart1 = <MMI_screen>.exe 2 

The Windows Display Properties settings must match the MMI Manager “Screen Layout.” (See Using 
MMI Manager below.) 

 

Using Action Center 
The Action Center is an instructor station software application used for traditional model control, 
activation of local operator actions, setting external conditions, and initiating malfunctions.  The 
Action Center saves action variable files with the .avr file extension and action files with the .act file 
extension.  In addition, the Action Center is capable of saving an ACSII log file with the .log file 
extension.  This section is intended to provide a basic overview of model control.  For additional 
information, see Action Center help; from the Action Center main menu, select Help > Contents. 
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Action Center Start Up 

When the Action Center is initially started, it attempts to connect to S_Master.  If this connection is 
complete, the model control toolbar is active: 

 

If the model control toolbar is not active, the user should verify that S_Master has been started, and 
that a model is running.  If the model control toolbar is still not active, do the following: 

Verify the proper settings in the S_Master à Socket Setup window.  When S_Master is running 
locally, this setting should be 127.0.0.1: 

 

Also select S_Master à Connect to attempt a new connection. 

Once connected to the model, the user should load up a set of action variables and actions as 
described below: 

Loading the AVR and ACT Files 
From the Action Center main menu, select File à Open.  The installed PRJ file should appear by 
default if the s:\ drive is mapped properly to the model folder (described below).  If not then locate 
the *.prj file and select Open.   Opening the project file installed by PlantSim should open the 
associated AVR and ACT files. 

To load an individual ACT or AVR file, select the File à Open again.  This time, change the file type 
to action files (*.act), or AVar files (*.avr) and choose the desired file. 

The Action Center supports three different views.  A view can be thought of as what you are looking 
at in the Action Center Window.  The main Action view (shown below) is active at startup.  The 
Pending view is used to list all actions that are active or pending.  The Log view is used to view a log 
of instructor station actions that have taken place since starting up the Action Center.  The three 
different views are selected from the View menu item or by choosing one of the first three icons on 
the main toolbar. 

Action Center example on next page 
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Figure 2: The Action Center. 

	
  

Model Control using Action Center 
	
  

 

Start/Stop the Model 
Model Control is easily accomplished using the Model Control toolbar.  The first two icons on this 
toolbar are used for starting and stopping the model:   

 Start button   

  Stop button   
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In addition to using the model control toolbar icons to start/stop the model, the Control menu can be 
used from the Action Center main menu, or the user may use the keyboard by selecting the F3 key 
to start the model and the F4 key to stop the model. 

Load Data Image (*.ic file) 
PlantSim comes packaged with Initial Condition files, which may be used to set the model to a pre-
defined state.   

Select Control > Load Data Image > Initial Condition, or use the Model Control toolbar: 

 

Figure 3: Use the drop-down box to select an IC, and click the button to load it. 

	
  
 

Figure 4: Click the file open icon on the Model Control toolbar to select an image to load. 

 

The open data image window is displayed below: 

 

Figure 5: Open data Image window. 

This window can be used to load *.ic, *.ssf, *.spf, and *.tbt files.  See the Glossary or Using 
S_Master for more information on these file types. 

Saving, Restoring, and Deleting Data Images 
Data images can be saved and restored from the Action Center directly.  Deletion of data images, 
however, must be performed via Windows Explorer as described below. 

� Saving 
The easiest way to save a data image is to use the save icon on the Model Control toolbar.  The 
"Save Data Image File" dialog box will be presented once this button is pressed.  The proper data 
image type should be selected, and the file name entered in the appropriate field.  Once all 
information has been entered, the user should press the "Save" button to save the data image. 
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� Restoring 
The easiest way to load a data image is to use the open icon on the Model Control toolbar.  The 
"Load Data Image File" dialog box will appear once this button is pressed.  The proper data image 
type should be selected, at which point, a list of only those data images will be presented.  The 
user should select the data image to be loaded and press the "Open" button to load the image.  

� Deleting 
Data images are deleted through Windows Explorer. If drive S: is properly mapped, then browse 
to the S: drive and select the desired data image files. After the particular data image file has 
been located, all files of that same name, but with the various different file extensions, should be 
deleted. 

  Initiating Actions 

Actions are sorted by file folders (or in a tree view). The first step in initiating an action is to locate 
the action by navigating through the action tree.  Once the action has been located, highlight the 
action by single clicking on the action icon.  Once highlighted, the action can be initiated by pressing 
the Green-light icon as shown above. The Green-light icon is located in the upper right-hand corner 
of the Action view window.  These steps are sometimes referred to as selecting the action and 
pressing "go." 

   Trending Action Variables 

Action variables can be easily added to G_Master for data collection and trending.  Before this feature 
can be used, G_Master must have been previously started.  To add an action variable to G_Master, 
simply highlight the action variable by clicking on it and pressing the G_Master icon as shown above.  
These steps are sometimes referred to as selecting the action variable and pressing "link."  If the link 
was successful, the first G_Master document will start collecting data for the new variable. 

  Configuring S_Master from the Action Center 

S_Master, not the Action Center, is responsible for saving timed backtrack files and pacing the 
simulator to run at the user selected time interval.  The Action Center can, however, configure 
S_Master to perform these events via the S_Master à Config Setup menu item.  When this menu 
item is selected, the "S_Master Configuration" dialog box is presented.  From this dialog box, the user 
should configure the following events: 

n Back Track Frequency & Number of Files 
The backtrack feature can be turned on or off via the check box presented in the “S_Master 
Configuration” dialog box.  In addition, the user can select the frequency at which the timed 
backtracks are to take place and the number of files to store. 

n Real Time Scale Factor 
The real time scale factor adjustment is where the user can speed up or slow down the 
simulation.  A factor of one indicates that the simulator calculations are performed at real-time, 
or in other words, one second of simulation time is equal to one second of clock time.  A factor 
greater than one is faster than real time, and a factor less than one is slower than real time.  
For example, a factor of 2 is twice as fast as real time, or one second of simulation time will be 
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performed in ½ second of clock time.  A factor of 0.5 is ½ as fast as real time, or one second of 
simulation time will be performed in 2 seconds of clock time.  In all cases, the selection of the 
real time scale factor is only a desired simulation speed as the limits at which the simulator can 
be executed are governed by the available hardware, size of the model, etc. 

Security 
Simulation managers have the ability to add/edit actions and action variables and can modify the 
setup configuration of the Action Center.  Simulation Managers also have the ability to add/edit users 
and user permissions. 

Simulation instructors have the ability to perform all of the traditional instructor station capabilities, 
such as start/stop the model, initiate malfunctions, etc.  Instructors do not, however, have the ability 
to configure the Action Center, add/edit user permissions, or modify actions or action variables. 

Simulation students’ use of the instructor station is limited to basic model control and activation of 
local operator actions. 

 Action Center Configuration 
Action Center requires that the S:\ drive be mapped to the model folder. (A typical folder containing 
model files would be C:\PlantSim\PS4\PS4sim0.) 

Action Center is configured by the PlantSim installation program to start up using a batch file that 
maps s:\ locally to the installed model folder. 

 

Using S_Master 
S_Master’s main function is to connect to the model and service client requests.  The client requests 
include model commands, such as start/stop, save/restore state, etc. S_Master also serves other 
requests, such as getting or setting individual variables or lists of variables.  For additional 
information, see the S_Master help. From the S_Master main menu, select Help à Contents. 

S_Master saves simulator data images with the following file extensions .ic, .ssf, .tbt, and .spf. (See 
details in Data Images section.)  In addition, S_Master keeps log files that are automatically saved 
with the .slg file extension. 

Data Images 
The term data image is used to describe all simulator run-time data.  Thus, the different types of 
data images are Initial Condition (*.ic) files, Saved Snapshot (*.ssf) files, Timed Backtrack (*.tbt) 
files, and Parameter (*.spf) files.  All of the data image types are binary files and are discussed 
below. 

Saved Snapshot File (.ssf) 
The saved snapshot file is a file stored on disk that contains the state of the simulation at a given 
point in time.  This image contains all simulator variables, including states and parameters. 
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Timed Backtrack File (.tbt) 
A timed backtrack file is a saved snapshot file that has been automatically saved by the simulator.  
The number of backtrack files saved and frequency in between file saves are user configurable.  
Timed backtrack files differ from saved snapshot files simply by the way they were saved.  Timed 
backtrack files are saved automatically by the simulator while saved snapshot files have to be saved 
by a user. 

Parameter Files (.spf) 
Parameter files are a subset of simulator data.  The intent is that parameter files contain only 
simulator variables that do not change from one time-step to the next.  An example of a parameter is 
an actuator time constant.  Sometimes, however, it is difficult to define whether a variable is a 
parameter or not.  Because of this difficulty, the distinction between parameter and non-parameter 
variables has been left up to the model developer. 

Default Parameter File 
The default parameter file is a special parameter file that is always loaded with an initial condition.  If 
the simulator detects that the default parameter file does not exist, it will automatically create one.  
The name of the default parameter file is user configurable. 

IC’s or Initial Condition Files (.ic) 
An IC file differs from a saved snapshot file in that after the IC is loaded, the default parameter set is 
restored.  Thus, an IC can be thought of as a saved snapshot file with less parameters. 

 

Using MMI Manager 
MMI manager is a Simulation Tool Application whose purpose is to coordinate information between 
the MMI screen(s) and the simulation executive application (S_Master). To that end, the MMI 
Manager was designed to do the following: 

� Provide advanced communications between the MMI screens and the Simulation Executive 
application 

� Provide screen to screen communication 

� Provide personality dependent functions as shown below: 

n Interface with personality keyboard and manage common keyboard functions 

n Manage MMI screen placement 

n Manage personality dependent alarms 

The MMI Manger communicates with S_Master through a set of standard message protocols that 
operate over TCP/IP.  

The MMI Manager starts automatically when one of the MMI screens is loaded. 

For additional information, see MMI Manager Help. From the MMI Manager main menu, select 
Help > Contents. 
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MMI Manager Configuration 
MMI Manager starts automatically when an MMI screen is started.  MMI Manager should be 
configured to run properly by the PlantSim installation program.  Further configuration may be 
required to use multiple monitors or to connect to S_Master across the network. 

The MMI Manger menu is described below: 

 

Figure 6: Select File > Exit. 

File > Exit:  
This closes the MMI manager, and all open MMI screens registered. This does NOT close the 
simulation. 

Simulation > Configure: 
This allows configuration of various options. 

 

Figure 7: Simulation > Configure opens this window. 

 

Configuration Options (from MMI32 Configure window) 
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“Address of computer running S_Master” (Communications) 
…Is the TCP/IP address of the PC running the model. It is recommended that the address be entered 
in "Dot" notation, such as 127.0.0.1, rather than symbolic name format (MYComputer). If, however, 
the computer running S_Master has a dynamic IP address, you must use the symbolic name format. 
Your network administrator should be able to help with any questions on TCP/IP addressing. 

Virtual DCS ID 
Modifying this entry allows you to select the Virtual DCS ID for this computer. The Virtual DCS ID is 
an identification tag assigned to an MMI manager computer to identify which DCS workstation the 
MMI manager represents. Various MMI Manager computers can share the same Virtual DCS ID, but 
one MMI Manager cannot have multiple Virtual DCS ID's. 

Screen Layout 
The Screen layout defines how the MMI screens appear on the desktop. The screen layout MUST 
match the Display settings. In most cases for a single monitor system, select 1x1; for a dual monitor 
system with monitors side-by-side, select 2x1.  The DDN for a multiple monitor setup starts at the 
top left for DDN 1 and continues top to bottom. See Glossary description of DDN. 

The value chosen may also be dependent upon the resolution of the main MMI screen and the 
resolution of the current computer. For example, assume the MMI screens were designed for an 
800x600 resolution monitor. If the computer currently executing the MMI Manager has a screen 
resolution of 800x600 pixels, then a 1x1 layout should be selected. If a dual monitor system is 
present, each monitor should be configured to display 800x600 pixels, and a 1x2 or 2x1 screen 
layout should be selected. If a single monitor system is present and configured to display 1600x1200 
pixels, then a 2x2 screen layout option should be selected.  

Timeouts 
The communication timeouts affect the communications between MMI32 and S_Master; the default 
settings should not be changed for PlantSim. 

� Personality Config: 
The Personality Config menu item provides the means to configure all personalities loaded. Once 
this menu item is selected, the "Configure" method will be called for each personality in memory. 
Personalities are loaded only when a MMI screen has registered with the MMI Manager. 

� Communications:  
The Communications menu allows the user to connect and disconnect from S_Master. The 
"Communications/Reset All Coms" menu item allows the user to reset the MMI Manager without 
having to exit the program. 

� Alarms: 
The Alarms menu item provides a mechanism to silence and sound all alarms horns. The 
functionality of this menu item is dependent upon the personality DLL’s loaded. 

View Menu 
The View Menu allows the user to turn on and off viewing of the Toolbar and Status bar. 

Help Menu 
The Help menu allows the user to display the online help file. In addition, the "About" item in the help 
menu allows the user to display the current version and build time of the MMI Manager. 
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Using G_master 
Graph Master or G_Master is a real-time trending application.  G_Master communicates a list of 
variables to be trended to S_Master.  S_Master, in return, responds with the current value of these 
variables at each S_Master defined communication interval.  G_Master displays the data in a number 
of different formats, performs simple statistical calculations of the data, and has the capability to 
export the data for additional external processing.   For additional information, see G_Master help. 
From the G_Master main menu, select Help à Contents. 

G_Master saves data files with the .gmg file extension.  G_Master can export its data in delimited 
ASCII text files with the .tmd file extension. 

G_Master Startup 
A blank document is created automatically when G_Master is started. This blank document is 
essentially a trend chart that contains no variables to be trended. You can choose to add variables to 
trend to this graph, or you may decide to close this graph and open a pre-defined file. The Windows 
standard file/open menu items or toolbar icons can be used to open/save G_Master data files. 

 

Figure 8: G_Master Trend Display and Trainee Performance Review Results. 
G_Master allows the user to not only have complete control over which variables to trend, but also how to display 
them.  
The data can then be exported and imported into other programs. 
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Adding Trends to G_Master 
Trends are added to G_Master via the "Edit/Add Trend" menu item or the "Add Trend Icon" as 
presented at the beginning of this paragraph.  Once the add trend option has been selected, the "Add 
Variable" dialog box will be presented. This dialog box contains fields for the ACSL variable name, a 
Description, and a Scale & Offset factor. If you are familiar with ACSL (the simulation language used 
in the process model) and MMS (the application used to build the process model), you can fill out this 
form by hand.  If, however, you are not familiar with ACSL & MMS, you can obtain the list of 
predefined action variables from the Action Center.  In order to obtain a list of action variables, the 
Action Center must be running on the same computer and have a set of Action Variables loaded.  
Once this condition is met, you can press the "Action Center" button on G_Master’s "Add Variable 
Dialog" box after "Add Trend" is selected. This button will present you with a list of action variables to 
choose from for trending. 

Removing Trends From G_Master 
Trends are removed from G_Master via the "Edit/Remove Trend" menu item or the "Remove Trend 
Icon" as presented at the beginning of this paragraph.  Once the remove trend option has been 
selected, the "Remove from List" dialog box will be presented.  To remove trends, simply select the 
variables to remove from this list and press enter or the "OK" button. 

G_Master Views, Windows & Documents 
G_Master allows for the viewing of trend data in one of three different ways.  Each of these ways is 
called a view.  The three views are Digital, Single Axis, or Multiple Axis.  The digital view allows for 
viewing in numerical form the current value of any variable being collected.  The Single Axis view 
allows for viewing all or a subset of variables being collected on a common axis.  The multiple axis 
view allows for viewing each variable on its own axis.  The three different views are selected under 
the "view" menu item. 

Each view of the data can be seen at the same time by using three different windows.  For example, 
if a digital display is currently being viewed, the "Window/New" menu item can be selected which will 
present a new window for that same data.  Then, a different view can be selected for that window 
from the "View \ Graph - Multiple Axes" menu and variables can be selected from the "View \ Set 
Trend Visibility" menu.  Thus two different views of the same data can be setup.  There is no limit to 
the number of different windows that can be setup for each document. 

A G_Master document contains all the data collected for each variable added.  G_Master is a multiple 
document application so that multiple G_Master documents can be opened at one time.  When you 
save a G_Master document into a .GMG file, you save the trend data, the configuration for each 
window opened, and the ranges and scales for each variable trended.  The name of the document 
loaded is displayed on each window and followed by a colon and the window number. 

Setting Trend Visibility 
Sometimes, it is not desirable to display all data collected on a G_Master document in a particular graph.  
Thus, you must tell G_Master what variables you want to be displayed when a new window is opened.  
You do this by choosing the "View/Set Trend Visibility" menu item.  When you select the "Set Trend 
Visibility" menu item, you will be presented with a list of variables available for trending.  You should 
select the variables you want to appear on the new window and press "OK."  If a variable you want to 
trend is not in the list, it must be added to the document as described above. 
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Changing Scales 
The Scale menu item on G_Master allows you to change the time scale, or y-axis scale.  You must select 
from a series of pre-defined time scales but have flexibility in choosing the y-axis scale.  If you want 
G_Master to automatically scale the y-axis based upon the data available, choose "Auto."  If you want to 
enter the upper and lower limits for the y-axis, choose "Manual.”  If the current view is a multiple axis 
view, you will have to select the trend for which the new scale applies. 

Printing From G_Master 
G_Master prints trend data via the Windows Print functionality. Thus before G_Master can print, a Windows 
printer must be installed.  G_Master is capable of printing in black & white or color to a local or network 
printer, depending upon the Windows NT printer setup.  See the Windows NT documentation for installing 
printer drivers and printing to network printers.  Once the printer has been installed, you can print any 
G_Master window by selecting the window to be printed, re-sizing the window to get the desired aspect 
ratio, and pressing the print icon on the toolbar.  Alternatively, you can choose the "File/Print Preview" menu 
item to preview the printed image.  Printer settings are modified via the "File/Page Setup" menu item.  
Some printers require the "Print Text as Graphics" option be selected in order to print properly. 

Security 
The simulation managers and instructors have full use of G_Master. Students, however, have limited 
access.  A student can execute the G_Master application, but the student is not allowed to view the 
information or edit the information being collected. Because of these limitations, G_Master will start up in 
a minimized state when initiated by a student. The student will not be able maximize G_Master or perform 
any other actions except close.  

 

PlantSim Unit Startup Instructions 
Unit 1 Startup 
See document:  
PlantSim1StartupInst.pdf  

Unit 2 Startup 
See document:  
PlantSim2StartupInst.pdf  

Unit 4 Startup 
See document:  
PlantSim4StartupInst.pdf  



	
  

 
 

 
18  User’s Guide to PlantSim v4.1 | ©2014 nHance Technologies, Inc.  p 434.582.6110  w www.plantsim.com 

Glossary of Terms 
Action Center 
The Action Center is a Simulation Tool application used for traditional model control, activation of 
local operator actions, setting external conditions, and initiating malfunctions. The Action Center 
saves action variable files with the .AVR file extension and action files with the .ACT file extension. In 
addition, the Action Center is capable of saving an ACSII log file with the .LOG file extension. 

Data Image 
The term data image is used to describe all simulator run-time data. Thus, the different types of data 
images are Initial Condition (*.IC) files, Saved Snapshot (*.SSF) files, Timed Backtrack (*.TBT) files, 
and Parameter (*.SPF) files. 

DCS 
Generally, the Distributed Control System is the hardware used to control a physical process. There 
are a number of different manufactures of DCS hardware, each of which uses its own proprietary Man 
Machine Interface to allow the operators to control the plant via the MMI. 

DDN 
DCS Desktop Number  Every DCS desktop on a PC is assigned a number. The DCS Desktop (PC 
monitor) in the upper left position is assigned the DDN of 1. The DDN is incremented for each DCS 
Desktop from top to bottom: 

 

Figure 9: DDN Numbering 

G_Master 
Graph Master is a Simulation Tool component used for trending simulator data and trainee 
performance monitoring. G_Master saves data files with the .GMG file extension. G_Master is capable 
of exporting its data in delimited ASCII text files with the .TMD file extension. 

HMI 
Human-Machine Interface is a collection of Graphical User Interfaces designed to simplify operator 
interaction with a computer process. Typically, this is used to describe the control screens operators 
use to control an industrial process (also known as MMI). 
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IC (*.ic File) 
This is an Initial Condition File used by S_Master  This file differs from a saved snapshot file in that 
after the IC is loaded, the default parameter set is restored. Thus, an IC can be thought of as a saved 
snapshot file, less parameters. 

MMI 
Man-Machine Interface is a collection of Graphical User Interfaces designed to simplify operator 
interaction with a computer process. Typically used to describe the control screens operators use to 
control an industrial process (also known as HMI). 

MMI32 

MMI manager is a Simulation Tool Application whose purpose is to coordinate information between 
the MMI screen(s) and the simulation executive application (S_Master). 

Personality 
The MMI Manager supports multiple "Personalities." A personality is simply a term used to represent 
DCS specific emulation requirements such as interfacing with a DCS keyboard, handling DCS specific 
alarm methods, etc. Using the personality approach, support can be provided to emulate different 
DCS MMIs by simply generating a DCS specific DLL rather than modifying the MMI Manager. For 
those applications where no specific DCS MMI is being emulated, the Generic Personality should be 
used. 

Personality DLL 
A Personality DLL is loaded by the MMI Manager and performs DCS specific emulation tasks such as 
interface with a DCS keyboard. 

Parameter Files (*.spf) 
Parameter files are a subset of simulator data.  The intent is that parameter files contain only 
simulator variables that do not change from one time-step to the next.  An example of a parameter is 
an actuator time constant.  Sometimes, however, it is difficult to define whether a variable is a 
parameter or not.  Because of this difficulty, the distinction between parameter and non-parameter 
variables has been left up to the model developer. 

S_Master 
Simulation Master is the simulation run-time executive. The S_Master application runs on the main 
computer and among its many jobs, services communication requests from client applications such as 
G_Master and the Action Center. S_Master saves simulator data images with the following file 
extensions: .IC, .SSF, .TBT, and .SPF. In addition, S_Master keeps log files that are automatically 
saved with the .SLG file extension. 

Saved Snapshot File (*.ssf) 
The saved snapshot file is a file stored on disk that contains the state of the simulator at a given 
point in time. This image contains all simulator variables including states and parameters. 

Timed Backtrack File (*.tbt) 
A timed backtrack file is a saved snapshot file that has been automatically saved by the simulator. 

 


